Email and messaging slow to respond
Incident Report for Eventric
Resolved
The incident has been resolved, however several messages are still waiting to be delivered. In the event that you're waiting for one (like a password reset), please re-attempt now.
Posted Jun 15, 2022 - 15:48 CDT
Update
We are continuing to investigate this issue.
Posted Jun 15, 2022 - 15:06 CDT
Investigating
Currently, Eventric email and internal Master Tour messaging is slow to process - we're investigating this issue.
Posted Jun 15, 2022 - 15:06 CDT
This incident affected: Master Tour.